QB Issue Resolution:

Intuit will not be able to help you, since you did not purchase from them.

On another thought, usually a bookkeeper/accountant will/should be willing to purchase the newer versions to accommodate their clients, esp. if they belong to the Pro Advisor program.

Resolution for Issue 'Hello I purchased quickbooks 2018 on amazon. I was hoping you can help me because I do not need 2018. My bookeeper has 2017 and we need same verison to operate in sync.' available: Yes (Solved).
Source: Intuit Community forum.

Hello I purchased quickbooks 2018 on amazon. I was hoping you can help me because I do not need 2018. My bookeeper has 2017 and we need same verison to operate in sync.: this issue or error code is a known issue in Quickbooks Online (QBO) and/or Quickbooks. Support for this issue is available either by self-service or paid support options. Experts are available to resolve your Quickbooks issue to ensure minimal downtime and continue running your business. First try to resolve the issue yourself by looking for a resolution described below. If it is a complex issue or you are unable to solve the issue, you may contact us by clicking here or by using other support options.

Support for accommodate
Quickbooks Repair Pro will resolve it efficiently and affordably. Guaranteed resolution of your issue, or you pay nothing!

Error Recovery for accommodate [Canada]
E-Tech is the #1 Quickbooks data migration and Conversion service provider.

Get 50% off Quickbooks Online

Click Here for 50% off!

Additional Support Options: