QB Issue Resolution:

You’ll have to purchase the product. Curious though why your bank is advising this, I would expect them to support the year version as long as Intuit does.

Resolution for Issue 'I operate with the latest version of Quickbooks for Mac 2012 (V13.0.14R15). My financial institution advises I must “upgrade” to QB for Mac 2014. Is that a purchase of new software, or simply an upgrade? That is, must I buy QB 2014?' available: Yes (Solved).
Source: Intuit Community forum.

I operate with the latest version of Quickbooks for Mac 2012 (V13.0.14R15). My financial institution advises I must “upgrade” to QB for Mac 2014. Is that a purchase of new software, or simply an upgrade? That is, must I buy QB 2014?: this issue or error code is a known issue in Quickbooks Online (QBO) and/or Quickbooks. Support for this issue is available either by self-service or paid support options. Experts are available to resolve your Quickbooks issue to ensure minimal downtime and continue running your business. First try to resolve the issue yourself by looking for a resolution described below. If it is a complex issue or you are unable to solve the issue, you may contact us by clicking here or by using other support options.

Support for Quickbooks
Quickbooks Repair Pro will resolve it efficiently and affordably. Guaranteed resolution of your issue, or you pay nothing!

Error Recovery for Quickbooks [Canada]
E-Tech is the #1 Quickbooks data migration and Conversion service provider.

Get 50% off Quickbooks Online

Click Here for 50% off!

Additional Support Options: