Yes you do. The 2008 program is not compatible with Sierra. You need to purchase the 2016 program. You may need intuit’s help in upgrading your file.

Resolution for '2008 program issue: 'I installed quick books on my Mac back in 2008. I recently did a system update which made my whole programe redundant. Do I have to repurchase the whole program again?' available: Yes.

The 2008 program issue or error code is a known issue in Quickbooks Online (QBO) and/or Quickbooks. Support for this issue is available either by self-service or paid support options. Experts are available to resolve your Quickbooks issue to ensure minimal downtime and continue running your business. First try to resolve the 2008 program issue yourself by looking for a resolution described in the article. If it is a complex 2008 program issue or you are unable to solve the issue, you may contact us by clicking here or by using other 2008 program support options.

For more information about resolving issues related to 2008 program in Quickbooks/QBO or to get support for the issue 'I installed quick books on my Mac back in 2008. I recently did a system update which made my whole programe redundant. Do I have to repurchase the whole program again?', click the link below: