QuickBooks is not backwards compatible.  You cannot open a file from 2015 in 2013.  The bookkeeper should’ve known this and worked in QB 2013 on your file.  Now, you’ll have to upgrade to 2015 if you want to open the file.

Resolution for '2013 and 2015 lack issue: '2013 and 2015 lack of compatibility' available: Yes.

The 2013 and 2015 lack issue or error code is a known issue in Quickbooks Online (QBO) and/or Quickbooks. Support for this issue is available either by self-service or paid support options. Experts are available to resolve your Quickbooks issue to ensure minimal downtime and continue running your business. First try to resolve the 2013 and 2015 lack issue yourself by looking for a resolution described in the article. If it is a complex 2013 and 2015 lack issue or you are unable to solve the issue, you may contact us by clicking here or by using other 2013 and 2015 lack support options.

For more information about resolving issues related to 2013 and 2015 lack in Quickbooks/QBO or to get support for the issue '2013 and 2015 lack of compatibility', click the link below: