Any Quickbooks version which is 2014 edition or older than that is no longer supported by Quickbooks. The best option would be to buy the latest version of Quickbooks. In your case you could follow this link –

 

https://quickbooks.intuit.com/mac/

Resolution for 'Compatibility Error issue: 'QuickBooks 2014 Mac OS Compatibility Error' available: Yes.

The Compatibility Error issue or error code is a known issue in Quickbooks Online (QBO) and/or Quickbooks. Support for this issue is available either by self-service or paid support options. Experts are available to resolve your Quickbooks issue to ensure minimal downtime and continue running your business. First try to resolve the Compatibility Error issue yourself by looking for a resolution described in the article. If it is a complex Compatibility Error issue or you are unable to solve the issue, you may contact us by clicking here or by using other Compatibility Error support options.

For more information about resolving issues related to Compatibility Error in Quickbooks/QBO or to get support for the issue 'QuickBooks 2014 Mac OS Compatibility Error', click the link below: